Back to overview
Resolved

Service interruption caused by a global Amazon Web Services (AWS) outage affecting CloudFront services

Jul 16, 2026 at 11:25am UTC
Affected services
app.modelml.com

Resolved
Jul 16, 2026 at 11:25am UTC

We previously experienced a service interruption caused by a global Amazon Web Services (AWS) outage affecting CloudFront services, which began around 09:19 BST on July 16, 2026. This caused downstream elevated error rates in our authentication provider, which connects Model ML to our customers' identity providers (IdP).

No customer data was impacted. The outage affected only access to the Model ML web application and did not compromise data security or privacy.

AWS has resolved the underlying CloudFront issue as of 12:23 BST on July 16, 2026, and normal access to Model ML has been restored.